В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
beresnevarseny
beresnevarseny
04.05.2020 16:54 •  Информатика

По pascal abc ! поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит восьми: первое число-номер вертикали(при счете слева направо), а второе-номер по горизонтали(при счете снизу вверх). с клавиатуры вводятся четыре числа a, b, c,d, каждое из которых не превосходит восьми. на поле ( a,b ) расположен слон. написать программу, которая выводит на экран true, если слон угрожает полю ( c,d ) false в противном случае. примечание. слон может перемещаться строго по диагонали на произвольное число клеток.

Ответ:
ольга1480
ольга1480
03.07.2020 15:13
Program slon;
var a, b, c, d:integer;
begin
a:=0; b:=0; c:=0; d:=0;
while (a<1) or (a>8) do begin write ('Введите число от 1 до 8, a='); readln (a); end;
while (b<1) or (b>8) do begin write ('Введите число от 1 до 8, b='); readln (b); end;
while (c<1) or (c>8) do begin write ('Введите число от 1 до 8, c='); readln (c); end;
while (d<1) or (d>8) do begin write ('Введите число от 1 до 8, d='); readln (d); end;
if abs(a-c)=abs(b-d) then write ('true') else write ('false');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?