Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
KlodMone1
30.09.2021 05:21 •
Информатика
Напишите программу, которая определяет площадь четырехугольника по известным значениям его 4ех сторон и одной диагонали.
Ответ:
Nastya161003
03.07.2020 13:52
По формуле Герона
var a,b,c,d:real;
Begin
readln(a,b,c,d);
writeln( sqrt( ((a+b+c+d)/2-a)*((a+b+c+d)/2-a)*((a+b+c+d)/2-c)*((a+b+c+d)/2-d)));
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
77linnik
17.03.2021 13:43
Сходства растровой и векторной графики...
lizaknyazeva580
15.12.2021 12:14
компьютер Пишет Проверьте соединение кабеля на мониторе. после пару перезагрузка все запускается, как навечно решить эту проблему, а то чувствую что пекарне кирдык...
ArinaBelman18
01.07.2021 19:56
Написать программу, которая: 1. заполняет массив из n элементов случайными целыми числами на промежутке [-50; 50); 2. выводит заполненный массив на экран. 1 =n =100...
fertnyhaw
01.07.2021 19:56
Найдите индексы первого вхождения максимального элемента. выведите два числа: номер строки и номер столбца, в которых стоит наибольший элемент в двумерном массиве....
дарья2411по
01.07.2021 19:56
Заполнить квадратную матрицу из символов размером 10 на 10 элементов таким образом,чтобы выше главной диагонали располагались символы x ,на главной диагонали-символы...
KseniaRogalina
01.07.2021 19:56
Составить программу именно в №3 последовательно вводятся n целых чисел. сосчитать сколько из них с первым числом....
kirillbatalov2
19.09.2022 04:15
Последовательно вводятся n целых чисел сосчитать сколько из них с первым числом кумир...
кристина19841016
19.09.2022 04:15
Дан массив 10 элементов . заполнение и вывод при цикла . найти разность между максимальными и минимальными элементами массива...
кика20052
03.10.2020 00:19
Среди 30 элементов числовой последовательности 3-3 * cos (3 * n * n) выведите на экран: произведение положительных элементов ПАСКАЛЬ!...
samudoma2006
09.08.2022 09:55
В соответствии с кодовой таблицей ASCII каждую латинскую букву можно закодировать десятичным числом. Слово «file» кодируется как 102105108101. Какому слову соответствует...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,b,c,d:real;
Begin
readln(a,b,c,d);
writeln( sqrt( ((a+b+c+d)/2-a)*((a+b+c+d)/2-a)*((a+b+c+d)/2-c)*((a+b+c+d)/2-d)));
End.