В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
matkazina
matkazina
02.12.2020 06:53 •  Информатика

Напишите программу,подсчитывающую количество оценок за контрольную,если в классе 20 учеников)(в паскале)

Ответ:
Ласточка005
Ласточка005
03.07.2020 12:39
const
  students = 20;

var
  marks: byte := students;

begin
  writeln('Все пришли?');
  var c: string;
  readln(c);
  if not (c in ['Yes', '1', 'True', 'Да']) then
  begin
    writeln('Сколько не пришло?');
    var b: byte;
    readln(b);
    marks := (marks > b ? marks - b : 0);
   end;
  writeln(marks, ' оценок');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?