В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ооо321
ооо321
26.10.2020 02:00 •  Информатика

Написать программу которая по вводу с клавиатуры трех действительных чисел выводит на экран сообщение о том могут ли они являться сторонами треугольника

Ответ:
Z07701
Z07701
03.07.2020 12:16
Нужно воспользоваться свойством треугольников:
Любая сторона треугольника меньше суммы двух других сторон и больше их разности .
Pascal
Var a,b,c:integer;
begin
readln(a,b,c);
if (a<b+c) and (a>b-c) and (b<a+c) and (b>a-c) and (c<b+a) and (c>b-a) then
writeln('Yes')
else
writeln('No');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?