В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sanя7184214
Sanя7184214
11.04.2020 12:22 •  Информатика

Составьте программу для вычисления гипотенузы, периметра и площади прямоугольного треугольника, если известны его катеты.

Ответ:
szhanibekov
szhanibekov
01.10.2020 17:08

с - гипотенуза, а и b - катеты, тогда по теореме Пифагора: с² = а² + b², откуда с = √(а² + b²).

Р = а + b + c, S = 1/2 · ab.

program praym_treug;

var a,b,c,s,p:real;

begin

write('Введите катеты: '); readln(a,b);

c:=sqrt(a*a+b*b);

p:=a+b+c;

s:=1/2*a*b;

write('Гипотенуза = ',c:5:2,' Периметр = ',p:5:2,' Площадь = ',s:5:2);

end.

:5:2 - форматный вывод, т.е. ограничение на количество цифр в ответе. Для чисел типа real это важно, т.к. обычно в ответе после запятой много цифр (в случае форматного вывода  останется только 2 - в нашем случае)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?