Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Abrak24
02.03.2020 20:53 •
Информатика
Заполнить массив случайными числами в диапазоне и подсчитать отдельно число четных и нечетных элементов в программе с++
Ответ:
денисвеликий
03.07.2020 07:55
Вот что получилось
#include <iostream>
#include <time.h>
using namespace std;
void main()
{
setlocale(LC_ALL, "rus");
srand(time(NULL));
int mas[100],n,s1=0,s2=0;
cin>>n;
for(int i=1;i<=n;i++)
{
mas[i]=20 + rand() % 80;
if(mas[i]%2==0)
s2++;
else
s1++;
}
for(int i=1;i<=n;i++)
cout<<mas[i]<<" "; cout<<endl;
cout<<"Не четные:"<<s1<<endl<<"Четные:"<<s2<<endl;
system("pause");
}
0,0
(0 оценок)
Популярные вопросы: Информатика
moto5
25.03.2020 11:47
Кузнечик выполнил следующий алгоритм 3 раза: вперёд 4 назад 6 определите, в какой точке оказался кузнечик?...
знатокслава
25.03.2020 11:47
Составить программу, которая печатает звездочки в шахматном порядке....
alina190383oztzns
17.12.2021 19:51
Что такое двоичный разряд? всмысле бит - минимальная единица количества информации, равная одному двоичному разряду. вот тут я немного не понял просто))...
Ирина1895031
17.03.2021 14:11
Вводится нат. число. найдите сумму этого числа и числа записанного теми же цифрами в обратном порядке...
daniilnz1
15.09.2022 07:47
Вводится нат.число.найти сумму этого числа и числа записанного теми же цифрами в обратном порядке. надо сегодня утром последние на паскале...
Отлишник88
21.01.2020 10:09
Які функції виконує редактор тексту?...
вошл
01.06.2022 09:09
Решить на языке паскаль с операторами цикла while и repeat: напечатать положительные значения y=sin x, если x=1, 2, . 40 , заранее ....
Сирена11111
25.02.2023 13:43
Выполнить сложение двоичных чисел: x=1011,1 ,y=1101,01 и z=11101,11...
Yury28
26.09.2020 01:47
Почему когда я ввожу положительные и отрицательные число, программа пишет, что нет отрицательных чисел либо положительных. это исправить. паскаль...
lozhe4ka
28.02.2022 16:55
почему художественный фильм о Ю.Гагарине так и не был запущен в производство?по рассказу МАЛЕНЬКИЕ РАССКАЗЫ О БОЛЬШОЙ СУДЬБЕ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
#include <time.h>
using namespace std;
void main()
{
setlocale(LC_ALL, "rus");
srand(time(NULL));
int mas[100],n,s1=0,s2=0;
cin>>n;
for(int i=1;i<=n;i++)
{
mas[i]=20 + rand() % 80;
if(mas[i]%2==0)
s2++;
else
s1++;
}
for(int i=1;i<=n;i++)
cout<<mas[i]<<" "; cout<<endl;
cout<<"Не четные:"<<s1<<endl<<"Четные:"<<s2<<endl;
system("pause");
}