В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Abdulla234
Abdulla234
20.04.2022 05:13 •  Информатика

Напишите программу на языке паскаль через цикл repeat, которая вычисляет сумму: а)первых n натуральных чисел б)квадратов первых n натуральных чисел в)всех чётных чисел в диапазоне от 1 до n г)всех двузначных чисел

Ответ:
Margarita11mm
Margarita11mm
03.07.2020 07:26
Program A_1;
uses crt;
Var
  i,n,sum: integer;
begin
  write('Введите N ');
  readln(n);
  i:=0;
  sum:=0;
  repeat
    i:=i+1;
    sum:=sum+i;
  until i=n;
  writeln('Сумма чисел от 1 до ',n,' равна ',sum);
end.

Program B_2;
uses crt;
Var
  i,n,sum: integer;
begin
  write('Введите N ');
  readln(n);
  i:=0;
  sum:=0;
  repeat
    i:=i+1;
    sum:=sum+i*i;
  until i=n;
  writeln('Сумма квадратов чисел от 1 до ',n,' равна ',sum);
end.

Program V_3;
uses crt;
Var
  i,n,sum: integer;
begin
  write('Введите N ');
  readln(n);
  i:=0;
  sum:=0;
  repeat
    i:=i+1;
    if (i mod 2 = 0) then sum:=sum+i;
  until i=n;
  writeln('Сумма чётных чисел в диапазоне от 1 до ',n,' равна ',sum);
end.

Program G_4;
uses crt;
Var
  i,n,sum: integer;
begin
  i:=9;
  sum:=0;
  repeat
    i:=i+1;
    sum:=sum+i;
  until i=99;
  writeln('Сумма всех двузначных чисел равна ',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?