В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
олегБро666
олегБро666
10.08.2022 18:09 •  Информатика

Написать программу: "дано четырехзначное число.что больше: сумма цифр,стоящих на четных местах,или сумма цифр,стоящих на не четных местах? "

Ответ:
ekserukhova16
ekserukhova16
01.10.2020 17:13
Var a,s1,s2:integer;
begin
read (a);
if (a>=1000)and (a<=9999)then
begin
s1:=(a mod 10) + ((a mod 1000) div 100);
s2:=(a div 1000) + ((a mod 100) div 10);
if (s1>s2)then writeln ('Сумма цифр,стоящих на четных местах больше суммы цифр, стоящих на нечетных местах');
if (s1<s2)then writeln ('Сумма цифр,стоящих на нечетных местах больше суммы цифр, стоящих на четных местах');
if (s1=s2)then writeln ('Сумма цифр,стоящих на четных местах равна сумме цифр, стоящих на нечетных местах');
end
else writeln ('Вы ввели не 4-ёхзначное число');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?