В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Лкь4иц
Лкь4иц
18.10.2022 02:22 •  Информатика

Напишите программу которая получает возраст человека и выводит его возраст со словами: год,года или нужно) но программа должна быть простая,так как я учусь в соц.гуме)

Ответ:
Maowsk
Maowsk
03.07.2020 01:44
Var
 n:integer;
begin
 readln(n);
 if (n mod 10 = 1) and ((n mod 100) div 10<>1) then
  writeln(n,' год')
 else
  if ((n mod 10 = 2) or (n mod 10 = 3) or (n mod 10 = 4)) and ((n mod 100) div 10<>1) then
   writeln(n,' года')
  else
   writeln(n,' лет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?