В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
serguhovaannagmail
serguhovaannagmail
28.03.2022 01:04 •  Информатика

Написать программу с массивом и отсортировать его тремя разными сортировка методом прямого выбора.2. сортировка прямым обменом (методом «пузырька»)3. сортировка вставками.

Ответ:
AntihypeSPB
AntihypeSPB
02.07.2020 18:24

const

 n=10;

type  

 massive = array [1..n] of integer;

procedure select(mas : massive);

var

 i, j, k,tmp: integer;

begin

 for i:=1 to n-1 do

   begin

     k:=i;

     tmp:=mas[i];

     for j:=i+1 to n do

       if (mas[j]<tmp) then

         begin

           k:=j;

           tmp:=mas[j];

         end;

     mas[k]:=mas[i];

     mas[i]:=tmp;

   end;

 write('Сортировка выбором:');

 for i:=1 to n do

   write(' ',mas[i],', ');

end;

procedure bubble (mas : massive);

var

 i,j,tmp:integer;

begin  

 for i:=1 to n-1 do

   for j:=1 to n-i do

     if (mas[j]>mas[j+1]) then

       begin

         tmp:=mas[j];

         mas[j]:=mas[j+1];

         mas[j+1]:=tmp;

       end;

 write('Сортировка пузырьком:');

 for i:=1 to n do

   write(' ',mas[i],', ');

end;

procedure insert(mas : massive);

var

 i,j,k,tmp : integer;

begin

 for i:=2 to n do

   begin

     tmp:=mas[i];

     j:=1;

     while (tmp>mas[j]) do

       j:=j+1;

     for k:=i-1 downto j do

       mas[k+1]:=mas[k];

     mas[j]:=tmp;

   end;

write('Сортировка вставкой:');

for i:=1 to n do  

 write(' ',mas[i],', ');

end;  

var

i : integer;

a : massive;

begin

 randomize;

 write('Массив:');

 for i:=1 to n do

   begin

     a[i]:=random(100);

     write(a[i]:4);

   end;

 writeln;

 select(a);

 writeln;

 bubble(a);

 writeln;

 insert(a);

end.    

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?