В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
byrzakovskaya
byrzakovskaya
26.04.2023 17:26 •  Информатика

Составить программу нахождения максимального элемента в массиве из 30 чисел

Ответ:
главный8
главный8
01.10.2020 16:27
Эта автоматически тебе всё сделает.
Var i, n, max : Integer;
     a : array [1..30] of Integer;
 begin
    for i := 1 to 30 do
 begin
      Write('a[', i, ']='); 
      a[i]:=i+1;
      if max<a[i] then max:=a[i];
      writeln(a[i]);
end;
  writeln('Максимальный элемент равен: ',max);
end.

Если нужно будет ввести последовательность с клавиатуры, то вот:
Var i, n, max : Integer;
     a : array [1..30] of Integer;
 begin
    for i := 1 to 30 do
 begin
      Write('a[', i, ']='); 
      ReadLn (a[i]);
      if max<a[i] then max:=a[i];
end;
  writeln('Максимальный элемент равен: ',max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?