В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
aruzhaan2003
aruzhaan2003
02.02.2023 20:37 •  Информатика

Составьте программу,определяющую, является ли данное натуральное число простым. желательно с объяснением

Ответ:
Serator2006
Serator2006
01.10.2020 16:25
Пусть данное число n 
тогда мы будем проверять в цикле все числа от 2 до (n-1) на делимость, если делится => не простое как нибудь это отмечаем
C++ :
int n, i;
bool b=false;
cin>>n;
for (i=2; i<n; i++)
{if (n % i =0)
    {b=true;}
 else 
    {;)}

if (b=true)
{cout<<"no";}
else
{cout<<"yes";};
0,0(0 оценок)
Ответ:
ника5010
ника5010
01.10.2020 16:25
Pascal

program af; 
var a,l,k:integer; 
begin
read(a);
if a>0 then
k:=0;
for l:=1 to a do
if a mod l = 0 then k:=k+1;
if (k>=1) and (k<=2) then writeln ('Простое') else writeln ('Не простое');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?