В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
galihanowa2015
galihanowa2015
12.09.2022 17:42 •  Информатика

Составьте программу позволяющую определить являются ли числа a, b, c пифагоровыми тройками.

Ответ:
lgaksenk
lgaksenk
01.07.2020 22:58
Var
  a, b, c: real;

begin
  writeln('Введите числа a, b, c');
  readln(a, b, c);
  if (sqr(a) = sqr(b) + sqr(c)) or (sqr(b) = sqr(a) + sqr(c)) or (sqr(c) = sqr(a) + sqr(b)) then
    writeln('Данные числа являются пифагоровым тройками')
  else 
    writeln('Данные числа не являются пифагоровым тройками');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?