В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Dog2111
Dog2111
13.08.2020 01:02 •  Информатика

Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть сумма покупки больше 1000р

Ответ:
KOBPAHET
KOBPAHET
01.07.2020 22:54
Var
  a: real;
  
begin
  while a <= 1000 do
  begin
    writeln('Введите сумму покупки > 1000р');
    readln(a);
    if a > 1000 then break
    else writeln('Ошибка! Введенная сумма покупки <= 1000p');
  end;
  writeln('Стоимость покупки с учетом скидки 10%:  ', a * 0.9);
end.
Данная программа проверяет, больше 1000 или нет, введенная стоимость покупки. Можно сделать проще без проверки:
var
  a: real;
  
begin
  writeln('Введите сумму покупки > 1000р');
  readln(a);
  writeln('Стоимость покупки с учетом скидки 10%:  ', a * 0.9);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?