В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vuhopen
vuhopen
11.07.2022 16:56 •  Информатика

Написать программу в паскате которая должна находить большую цифру числа (числа integer) большая цифра числа это например число 53 большая это 5 а в числе 29 большая 9 и тд хелп

Ответ:
dykbguojd
dykbguojd
01.10.2020 15:21
Program test;
var a,i,z,max:int64;
begin
readln(a);
for i:=1 to Length(InttoStr(a)) do
beginz:=a mod 10;
a:=a div 10;
if max<z then max:=z;
end;
writeln(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?