В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vsjhffdsg
vsjhffdsg
04.08.2020 07:48 •  Информатика

Составить программу, которая запрашивает у пользователя целое двухзначное число и прибавляет к нему сумму его цифр.

Ответ:
iarik2008
iarik2008
24.05.2020 23:24

Program n1;
Uses CRT;
Var x,a,b: integer;
begin
ClrScr;
writeln('Vvedite x');
readln(x);
a:=x div 10;
b:=x mod 10;
Writeln(x,'+',a,'+',b,'=',x+a+b);
readln
end.

0,0(0 оценок)
Ответ:
milenluiz
milenluiz
24.05.2020 23:24

var a: 10..99;

begin

  readln(a);

  writeln(a+(a mod 10)+(a div 10));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?