Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Lisa2003black
13.11.2020 08:09 •
Информатика
Составьте программу вычисления суммы цифр трёхзначного числа а. значение а введите с клавиатуры.
Ответ:
ира1031
30.06.2020 20:48
Program summa_4isel;
Uses crt;
Var a,e,z,y,x:integer;
Begin
Writeln('Введите трехзначное число число');
Readln(a);
x:=a div 100;
y:=(a-x*100) div 10;
z:=a-y*10-x*100;
e:=x+y+z;
writeln('Сумма чисел ',x,' ',y,' и ',z,' равна ',e,'.');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Vikadianalol
24.07.2020 09:43
Составить программу,которая описывает массив структур-телефонный справочник одноклассников,в котором будут отражены ФИ,адрес,телефон,хобби Пусть в этом массиве отражены...
Svetic1985
21.08.2020 05:36
Какой вид математической зависимости между разрешающей экрана и объемом памяти графического файла?...
Wanemid
29.12.2020 04:09
Напишите результат, который будет получен при вычислении значения выражения, если известно, что а...
Хаченок1337
22.09.2021 17:35
Вкомнате 4 угла. в каждом углу мтоит компьютер. напротив каждого компьютера еще 1 компьютер. сколько компьютеров всего в комнате?...
MaXD1337
03.11.2020 03:01
Какую формулу нужно выбрать, чтобы определить минимальное из значений в диапазоне ячеек с C5 по C20? 1)=МИН(С5;С20) 2)=МИН(С5:С20) 3)=СЧЕТ(С5:С2О) 4)=СУММ(С5;С20)...
uefip
02.07.2021 00:56
Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке. Последовательность завершается числом 0, при считывании...
paperghost
26.12.2021 15:22
Десятичная:11Двоичная:Восмеричная:Шестнадцатеричная:...
Алена173
02.09.2021 00:26
По восприятия информация не бывает: символьнойзрительнойобонятельнойтекстовойзвуковой ...
Rexmane
04.08.2020 12:17
Цветной сканер имеет разрешение 512*1024 точек/дюйм2. Объем памяти, занимаемой просканированным изображением размером 2*4 дюйма, составляет 12 Мбайт. Какова выраженная...
Maria2604love
26.03.2022 21:13
Задание 2 ( ). Приведите пример словесной модели по биологии. Дайте полный, развёрнутый ответ не менее чем в 5 смысловых предложениях....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Uses crt;
Var a,e,z,y,x:integer;
Begin
Writeln('Введите трехзначное число число');
Readln(a);
x:=a div 100;
y:=(a-x*100) div 10;
z:=a-y*10-x*100;
e:=x+y+z;
writeln('Сумма чисел ',x,' ',y,' и ',z,' равна ',e,'.');
end.