В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Онил180
Онил180
11.04.2022 22:15 •  Информатика

Записать алгоритм и написать программу циклического перемещения влево значений между переменными а, b, c

Ответ:
Dan3251
Dan3251
29.06.2020 18:33
Program gt;
var a,b,c,k:integer;
begin
read(k);
{k-на какое число шагов надо переместит числа a b c влево}
k:=k mod 3;
if(k=0)then writeln(a,' ',b,' ',c);
if(k=1)then writeln(b,' ',c,' ',a);
if(k=2)then writeln(c,' ',a,' ',b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?