В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lol6633
lol6633
03.05.2023 08:35 •  Информатика

Написать программу, которая печатает true или false в зависимости от того, выполняются или нет заданные условия: - квадрат заданного трехзначного числа равен кубу суммы цифр этого числа; -точка с координатами (x,y)принадлежит части плоскости,лежащей между прямыми x=m,x=n(m

Ответ:
Kukitoria666
Kukitoria666
24.05.2020 22:46

var b: 100..999;

      s: word;

      x, y, m, n: integer;

begin

  writeln('Введите трехзначное число');

  readln(b);

  s:=(b mod 10)+((b mod 100)div 10)+(b div 100); //сумма цифр трехзначного числа

  if sqr(b)=sqr(s)*s then writeln('True')

  else writeln('False');

  writeln('Введите координаты х и у');

  readln(x, y);

  writeln('Введите m и n');

  readln(m, n);

  if (x>m)and(x<n) then writeln('True')

  else writeln('False');

end.

  

     

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?