Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Aresn
01.01.2020 20:23 •
Информатика
Составить программу поиска больших чем соседние элементов массива l из 16 чисел. значения элементов массива рассчитать по формуле cosd/d,где d номер элемента массива.
Ответ:
Eliman1
01.10.2020 14:14
VAR
i: Integer;
a: Array [1..16] of Real;
BEGIN
For i := 1 to 16 do begin
a[i] := Cos(i) / i;
Writeln('L[',i,'] = ',a[i]); End;
Writeln;
For i := 2 to 15 do
If (a[i] > a[i-1])and(a[i] > a[i+1]) then Writeln('L[',i,'] = ',a[i]);
END.
0,0
(0 оценок)
Популярные вопросы: Информатика
vfedkina35
24.05.2022 22:29
Какие преимущества имеет растровый кодирования рисунков? * 1)можно использовать для рисунков любого типа 2)рисунок разбивается на пиксели 3)лучший для кодирования чертежей...
amiranur1
17.03.2022 17:23
Дана последовательность, расположить ее элементы, кратные 3, по убыванию.(паскаль)...
alenaalefirova
11.06.2021 15:16
Создать стек из случайных целых чисел и найти в нем максимальное и минимальное значение. (решить в паскале)...
tatianaishenko1
21.04.2022 00:59
Даны описания: type linia =array () of integer; var x, y : linia ; напиши программу, которая подсчитывает произведение последних пяти элементов переменной y....
Богдан2281667
13.10.2022 11:13
Преобразуйте число 11110 из двоичного в десятичное, восьмеричное, шестнадцатеричное...
elisbuh
15.02.2022 16:32
число 622 в шестнадцатиразрядном представлении имеет вид...
ого23
26.11.2020 22:57
Зашифруйте слово редактор при ключа 174...
xxxxxxxx13
31.07.2022 19:54
На алгоритмическом языке алгоритм позволяющий из полного сосуда емкостью 16 л отлить половину пользуясь двумя пустыми емкостью 7 и 3 л не могу решить...
Ангелина7102
18.09.2021 21:18
Реально, кто шарит, . это паскаль p.s. программисты красавцы...
rozvalova04
16.09.2021 09:36
Написать программу в ! ! , заранее...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i: Integer;
a: Array [1..16] of Real;
BEGIN
For i := 1 to 16 do begin
a[i] := Cos(i) / i;
Writeln('L[',i,'] = ',a[i]); End;
Writeln;
For i := 2 to 15 do
If (a[i] > a[i-1])and(a[i] > a[i+1]) then Writeln('L[',i,'] = ',a[i]);
END.