В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
happycatcom
happycatcom
18.12.2022 15:12 •  Информатика

1.составить программу и алгоритм находящую сумму цифр трехзначного числа 2.составить программу и алгоритм находящую все простые делители заданного числа

Ответ:
goshan14
goshan14
28.06.2020 15:46
Program gt;
var s,a,b,c,n:longint;
begin
read(n);
a:=n div 100;
b:=(n mod 100)div 10;
c:=n mod 10;
s:=a+b+c;
writeln(s);
end.
2)
program gt;
label 1;
var p,n,i,j:longint;
begin
read(n);
for i:=2 to n do
begin
if(n mod i=0)then begin
p:=round(sqrt(i));
for j:=2 to p do
begin
if(i mod j=0)then goto 1;
end;
writeln(i);
1:
end;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?