В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

C++ #include Написать программу, которая позволяет игроку выбрать (купить)
персонажа и оружие, после чего показывает его выбор и состояние
кошелька. Изначально на счету игрока – 1000 монет. Предусмотреть
обработку ошибок ввода и возможную нехватку средств.

Ответ:
Ольчик071196
Ольчик071196
30.05.2023 22:05

#include <iostream>

#include <limits>

int main() {

// Инициализация начальных значений

int playerCoins = 1000;

std::string character;

std::string weapon;

// Вывод доступных персонажей и оружия

std::cout << "Доступные персонажи: A, B, C" << std::endl;

std::cout << "Доступное оружие: X, Y, Z" << std::endl;

// Выбор персонажа

std::cout << "Выберите персонажа (A, B, C): ";

std::cin >> character;

// Проверка на ошибку ввода

if (character != "A" && character != "B" && character != "C") {

std::cout << "Ошибка ввода. Выбран недопустимый персонаж." << std::endl;

return 1;

}

// Выбор оружия

std::cout << "Выберите оружие (X, Y, Z): ";

std::cin >> weapon;

// Проверка на ошибку ввода

if (weapon != "X" && weapon != "Y" && weapon != "Z") {

std::cout << "Ошибка ввода. Выбрано недопустимое оружие." << std::endl;

return 1;

}

// Проверка на доступность средств

int characterCost = 500;

int weaponCost = 300;

if (playerCoins < characterCost || playerCoins < weaponCost) {

std::cout << "Нехватка средств." << std::endl;

return 1;

}

// Вычитание стоимости из кошелька игрока

playerCoins -= characterCost;

playerCoins -= weaponCost;

// Вывод выбора игрока и состояния кошелька

std::cout << "Выбранный персонаж: " << character << std::endl;

std::cout << "Выбранное оружие: " << weapon << std::endl;

std::cout << "Остаток на счете: " << playerCoins << " монет" << std::endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?