В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
andreikoval07
andreikoval07
23.08.2021 12:35 •  Информатика

Язык программирования C++ Используя указатели, напишите программу, которая возвращает элементы массива int a[10] через определяемую пользователем функцию присвоит любые значения целочисленного типа;

Ответ:
Witch23
Witch23
30.05.2023 19:22

#include <iostream>

void assignValues(int* array, int size) {

   std::cout << "Введите " << size << " целых чисел:\n";

   for (int i = 0; i < size; i++) {

       std::cin >> array[i];

   }

}

int main() {

   int a[10];

   assignValues(a, 10);

   std: :cout << "Введенные значения массива:\n";

   for (int i = 0; i < 10; i++) {

       std::cout << a[i] << " ";

   }

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?