В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
maks1974
maks1974
21.07.2022 21:23 •  Информатика

Напишите программу на языке программирования Python, которая принимает список чисел от пользователя и выводит только четные числа из списка. Ввод:
2 5 8 12 17 20
Вывод
Четные числа в списке:
2
8
12
20

Ответ:
Nicalat
Nicalat
30.05.2023 15:03

Развернутый вариант:

for i in map(int, input().split()):

   if i % 2 == 0:

       print(i)

Краткий вариант:

print(*[i for i in map(int, input().split()) if i % 2 == 0], sep='\n')


Напишите программу на языке программирования Python, которая принимает список чисел от пользователя
Напишите программу на языке программирования Python, которая принимает список чисел от пользователя
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?