В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
genagnatyk123
genagnatyk123
24.04.2023 10:48 •  Информатика

Дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив из 30 ти элементов написать программу которая позволяет найти среднее арифметическое положительных элементов массива

Ответ:
dauren1mukumov
dauren1mukumov
28.06.2020 08:41
Тебе на поскале судя по всему надо, я его давно изучал синтаксис позабыл но алгоритм могу подсказать
1)
Var arr:массив(от 0 до 6);
begin
пока i<6 //ввод массива 
readln(arr[i]);
конец;
writeln((i[1]+i[5])/2);//вывод среднего числа
end.
2)задача описана некорректно
3)
Var arr:массив(от 0 до 29),n:integer;
begin
пока i<30 //ввод массива 
readln(arr[i]);
конец;
пока j<29
n=n+arr[j];
конец;
writeln(N/30);//вывод среднего числа
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?