В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
KirillK2014
KirillK2014
13.05.2020 04:41 •  Информатика

C++ ПОЛНАЯ ПРОГРАММА НОК
Напишите программу, которая вычисляет наименьшее общее кратное двух чисел.

Входные данные

Входная строка содержит два натуральных числа, разделённые пробелом, — a и b. Гарантируется, что ответ не превосходит 2⋅10^9
Выходные данные

Программа должна вывести одно натуральное число: НОК заданных чисел.

Примеры
Ввод
14 21
Вывод
42

Ответ:
200775данил1717
200775данил1717
19.07.2022 15:02

Объяснение:

#include <iostream>

using namespace std;

long nod (int a, int b)  {

   return b == 0 ? a : nod (b, a % b);

}

int main() {

   int t1, t2;

   cin >> t1 >> t2;

   cout <<  t1 * (t2 / nod (t1, t2));

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?