В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nbuiluk
nbuiluk
23.11.2021 22:24 •  Информатика

3. Дан массив A = [20, 110, 40, 775, 95, 145, 1100]. Элементы этого массива Напишите программу сортировки в порядке возрастания и убывания,

Ответ:
Ilyavazhnov1995
Ilyavazhnov1995
19.03.2022 12:20

Відповідь:

#include <iostream>

using namespace std;

void sortmaxtomin(int *arr){

for(int i = 0; i < 7;i++){

 for(int j = 0; j < 6; j++){

  if(arr[i] > arr[j]){

   swap(arr[i], arr[j]);

  }

 }

}

}

void sortmintomax(int *arr){

for(int i = 0; i < 7;i++){

 for(int j = 0; j < 6; j++){

  if(arr[i] < arr[j]){

   swap(arr[i], arr[j]);

  }

 }

}

}

void printarr(int *arr){

for(int i = 0; i < 7; i++){

 cout << arr[i] << " ";

}

}

int main(){

setlocale(LC_ALL , "Rus");

int A[] = {20,110,40,775,95,145,1100};

cout << "Массив: ";

printarr(A);

cout << "\nСортировка по убыванию: ";

sortmaxtomin(A);

printarr(A);

cout << "\nСортировка по возрастанию: ";

sortmintomax(A);

printarr(A);

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?