В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nikipana
nikipana
27.11.2020 20:15 •  Информатика

Нужно написать программу в с# либо исправить мой код, который работает некорректно, Все как в условии using System;
namespace ConsoleApp3
{
class Program
{
public static void Main(string[] args)
{
const int n = 3, m=2;
int[] a = new int[n] { 1, 2, 3 };
double[] b = new double[m];
Console.WriteLine("Исходный массив");
for (int i = 0; i < n; i++)
{
Console.Write("{0} ", a[i]);
}
Console.WriteLine();
for (int i = 0; i < m; i++)
{
for (int j = 1; j <= n; j++)
{
b[i] += Math.Pow(a[j - 1], i + 1);
}
}
Console.WriteLine("Результат");
for (int i = 0; i < m; i++)
{
Console.Write("{0} ", b[i]);
Console.ReadKey();
}
}
}
}


Нужно написать программу в с# либо исправить мой код, который работает некорректно, Все как в услови

Ответ:
лимон2509
лимон2509
03.03.2022 11:10

// Массив из "a" заполнил псевдорандомными числами от 0 до 3 для наглядности

using System;

namespace ConsoleApp1

{

   internal class Program

   {

       private static void Main()

       {

           const int numsCount = 24;

           const int resCount = 10;

           double[] nums = new double[numsCount];

           double[] res = new double[resCount];

           var rand = new Random();

           for (int i = 0; i < numsCount; i++)

           {

               nums[i] = rand.Next(0, 4);

               Console.WriteLine($"a[{i}] = {nums[i]}");

           }

           Console.WriteLine();

           for (int i = 1; i <= resCount; i++)

           {

               double sum = 0;

               for (int j = 0; j < numsCount; j++)

                   sum += Math.Pow(nums[j], i);

               res[i - 1] = sum;

               Console.WriteLine($"b[{i - 1}] = {sum}");

           }

           Console.ReadLine();

       }

   }

}


Нужно написать программу в с# либо исправить мой код, который работает некорректно, Все как в услови
Нужно написать программу в с# либо исправить мой код, который работает некорректно, Все как в услови
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?