В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
jogangaj
jogangaj
25.01.2020 20:58 •  Информатика

Решите : 1) составьте программу ввода элементов массива [1..8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями.2) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с четными значениями.3) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями и количество элементов с нечетными значениями.4) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. выведите на экран исходный и полученный массивы.

Ответ:
asjadorn
asjadorn
26.06.2020 23:04
1)
uses crt;
const n=8;
var i:integer;
a:array[1..n] of integer;
begin
writeln('Input elements.');
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if a[i]<0 then
write(a[i],' ');
end.
2)
uses crt;
const n=10;
var i,t:integer;
a:array[1..n] of integer;
begin
randomize;
t:=0;
write('Массив: ');
for i:=1 to n do
begin
a[i]:=random(10,1);
write(a[i],' ');
if a[i] mod 2=0 then
t:=t+1;
end;
writeln(#13#10,t);
end.
3)
uses crt;
const n=10;
var i,sum,t:integer;
a:array[1..n] of integer;
begin
randomize;
sum:=0;
t:=0;
write('Массив: ');
for i:=1 to n do
begin
a[i]:=random(10,1);
write(a[i],' ');
if a[i] mod 2=0 then
sum:=sum+a[i]
else
t:=t+1;
end;
writeln(#13#10,sum,' ',t);
end.
4)
uses crt;
const n=10;
var i:integer;
a:array[1..n] of integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(10,1);
write(a[i],' ');
if a[i] mod 2=0 then
a[i]:=2*a[i]
else
a[i]:=3*a[i];
end;
write(#13#10);
for i:=1 to n do
write(a[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?