В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
girlgood2
girlgood2
20.11.2022 11:15 •  Информатика

Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до 10 в программе Phyton

Ответ:
сим666
сим666
07.02.2022 01:10

k = 0

for n in range(0,11,2):

   k += n

print(k)

0,0(0 оценок)
Ответ:
имилька
имилька
07.02.2022 01:10

Первый :

s = 0

for k in range(1,11):

   if k % 2 ==0:

       s += k

print(s)

Второй :

s = 0

for k in range(1,11):

   s += k*((k+1)%2)

print(s)

Третий :

print(sum([ k*((k+1)%2) for k in range(1,11)]))

*Четвертый :

print(sum([ k for k in range(0,11, 2)])) - подсказал второй ответ.

**Оказывается есть пятый, самый легкий :

print(sum(range(0,11,2)))  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?