В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Дан массив из 10 целых чисел от -20 до 20. написать программу,определяющая каких элементов в нем больше : положительных или отрицательных. решить,паскаль

Ответ:
klepekhin
klepekhin
26.06.2020 17:21
Program z10;
var a,b:Array [1..10] of integer;
i,q,k:integer;
Begin
Randomize;
q:=0;k:=0;
For i:=1 to 10 do
begin
a[i]:=random(40)-20;
if(a[i]<0)then q:=q+1;
if(a[i]>0)then k:=k+1;
end;
if(k>q)then writeln('положительных больше');
if(k<q)then writeln('отрицательных больше');
if(k=q)then writeln('положительных и отрицательных одинак.. кол-во');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?