В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Даны два натуральных числа m и n (m≤n). Напишите программу, которая выводит все числа от m до n включительно удовлетворяющие хотя бы одному из

условий:

● число кратно 12;

● число оканчивается на 5;

● число кратно 2 и 6 одновременно

Сделать все на Python

Ответ:
гулинахабирова
гулинахабирова
31.01.2022 20:30

m=int(input())

n=int(input())

for i in range(m,n+1):

   if i%12==0 or i%10==5 or (i%2==0 and i%6==0):

       print(i)

Объяснение:

0,0(0 оценок)
Ответ:
Direct228
Direct228
31.01.2022 20:30

m = int(input("m = "))

n = int(input("n = "))

num = range(m,n+1)

for n in num:

   if n % 12 == 0:

       print(n)

   if int(str(n)[-1]) == 5:

       print(n)

   if n % 2 == 0 and n % 2 == 0:

       print(n)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?