В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
arinkaapelsink
arinkaapelsink
22.10.2021 17:45 •  Информатика

. Напишите программу, вычисления рекурсивной функции. Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = 5 при n = 0,
F(n) = 3•F(n–4), если n положительное,
F(n) = F(n+3), если n отрицательное.
Вычислите чему равно значение функции F(43)?

Ответ:
Аннаlove2017
Аннаlove2017
27.01.2022 06:00

# Python

def F(n):

   if not n: return 5 # n == 0

   return (3*F(n-4)) if n > 0 else F(n+3)

F(43) = 7971615

0,0(0 оценок)
Ответ:
DaNa1517
DaNa1517
27.01.2022 06:00

питон:

def f(n):

   if n > 0:

       return 3 * f(n - 4)

   elif n < 0:

       return f(n + 3)

   else:

       return 5

print(f(43))


. Напишите программу, вычисления рекурсивной функции. Алгоритм вычисления значения функции F(n), где
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?