В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mariamuraskina9
mariamuraskina9
22.03.2020 16:26 •  Информатика

Нужно написать программу в Python. Вводится массив 10 целых чисел. Найти среднее значение четных элементов этого массива.

Ответ:
fokusPrise
fokusPrise
22.01.2022 22:40

Код:

arr = []

for i in range(10):

   arr.append(int(input()))

sum = 0

counter = 0

for i in arr:

   if i % 2 == 0:

       sum += i

       counter += 1

print("Среднее:", sum / counter)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?