В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Alina55332
Alina55332
16.02.2020 22:52 •  Информатика

Н.1. Составить программу, которая в последовательности целых чисел определяет кол-во элементов, подходящих  под условие: Число двузначное, нечетное, оканчивается на 3.
Сначала, пользователь вводит Кол-во чисел, затем сами числа.

Ответ:
hjhytu
hjhytu
22.01.2022 10:30

Pascal:

var

 n, i, a, c: Integer;

begin

 Read(n);

 c := 0;

 for i := 1 to n do begin

   Read(a);

   if (a div 100 = 0) and (a mod 10 = 3) then

     c := c + 1;

 end;

 WriteLn(c);

end.

Python:

n = int(input())

c = 0

for i in range(0, n):

   a = int(input())

   if (a // 100 == 0) and (a % 10 == 3):

       c += 1

print(str(c))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?