В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Мила20011
Мила20011
10.01.2020 16:46 •  Информатика

Написать программу, которая спрашивает у пользователя число, после этого выводит строку типа: 2 компьютера. В зависимости от введенного числа, программа должна корректно подставлять окончание для слово компьютер Пример:

Ввод: Пользователь ввел число 12

Вывод: 12 компьютеров
(Код должен работать с любым числом)

Ответ:
Даріна11111111
Даріна11111111
15.01.2022 23:20

n = int(input("введи число"))

if n%10== 1:

print(n,"компьютер")

elif (n%10==2 or n%10==3 or n%10==4):

print(n,"компьютера")

else:

print(n,"компьютеров")

0,0(0 оценок)
Ответ:
ravilmammadov09
ravilmammadov09
15.01.2022 23:20

Объяснение:

язык программирования (С++)

int main() {int a;cin>> a; if (a<4) {cout << a " компьютерa " ;}else {cout<< a"компьютеров"} return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?