В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
msteep6
msteep6
14.01.2021 12:28 •  Информатика

Написать программу на C++. Вставить новый элемент после последнего положительного.

Ответ:
danul1414
danul1414
11.01.2022 06:00

Решение в лоб:

#include <iostream>

#include <vector>

using namespace std;

int main() {

   vector<int> a(10);

   cout << "Enter array:" <<endl;

   for (int& i : a) {

       cin >> i;

   }

   int m = 0;

   for (int i = 0; i < a.size(); ++i) {

       if (a[i] > 0) {

           m = i + 1;

       }

   }

   cout << "Enter element to insert:" << endl;

   int v;

   cin >> v;

   a.insert(a.begin() + m, v);

   cout << "Result is below:" << endl;

   for(const int& i : a) {

       cout << i << ' ';

   }

   cout << endl;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?