В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Staz134
Staz134
15.05.2023 09:00 •  Информатика

«Списки в Python» №1.На вход программе подается одна строка, состоящая из слов на английском языке, разделенных
пробелами. Создайте из этой строки список слов, и выведите на экран первые две буквы каждого
слова в столбец.
№2.На вход программе подается одна строка, состоящая из слов на английском языке, разделенных
пробелами. Создайте из этой строки список слов, и выведите на экран первые две буквы каждого
слова в столбец.
№3На вход программе подается одна строка – натуральные числа, разделенные пробелами.
Отсортируйте список по возрастанию. Выведите результат на экран. Правда ли, что в списке
максимальный и минимальный элемент оканчиваются одной цифрой?

Ответ:
мосщчщчпзчх
мосщчщчпзчх
30.12.2021 22:00

1)

s = str(input()).split()

for a in s:

   print(a[0] + a[1])

#нет проверки на то что длина слов больше 1

2)

условие то же что и в 1)

3)

s = list(map(int, str(input()).split()))

s.sort()

print(s)

if str(min(s))[len(str(min(s)))-1] == str(max(s))[len(str(max(s)))-1]:

   print('Правда')

else:

   print('Неправда')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?