В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lialimur
Lialimur
31.01.2022 13:19 •  Информатика

Задача №70. Переставить соседние элементы Напишите программу, которая переставляет соседние элементы массива (1-й элемент поменять с 2-м, 3-й с 4-м и т.д. Если элементов нечетное число, то последний элемент остается на своем месте).

Входные данные
Сначала задано число N — количество элементов в массиве (1≤N≤35). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.

Выходные данные
Необходимо вывести массив, полученный после перестановки элементов.

Ответ:
Макс228336
Макс228336
30.12.2021 15:40

проф:

N = input()

a = [int(i) for i in input().split()]

for i in range(1, len(a), 2):

   a[i - 1], a[i] = a[i], a[i - 1]

print(a)

или мое лоховское:

N= input()

s = []

a = [int(i) for i in input().split()]

for i in range(1, len(a), 2):

   s.append(a[i])

   s.append(a[i-1])

if len(a) % 2 != 0:

   s.append(a[-1])

print(s)

Объяснение:

N нигде не используется

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?