В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
зайчик851
зайчик851
09.12.2022 03:38 •  Информатика

Составьте программу, котораясоставьте программу, которая заполняет массив а[1,,10 ] случайными числами в диапазоне от 0 до 10 , затем первый элемент меняет местами с максимальным элементом. выведите на экран исходный и полученный массивы.

Ответ:
Leralove20051
Leralove20051
26.06.2020 08:26
uses crt;
const N=10;
var a:array [1..N] of integer;
    x,pos,max:integer;
begin
     randomize;
     for x:=1 to N do
     begin
         a[x]:=random(11);
         writeln('a[',x,']:',a[x]);
     end;
     max:=1;
     for x:=1 to N do
          if a[x]>a[max] then max:=x;
     pos:=a[1];
     a[1]:=a[max];
     a[max]:=pos;
     writeln;
     for x:=1 to N do
         writeln('a[',x,']:',a[x]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?