В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Три точки а(х₁; у₁),в(х₂; у₂),с(х₃; у₃) своими координатами.написать программу, которая определяет,какая из этих точек ближе к началу координат.

Ответ:
coolsceleton98
coolsceleton98
26.06.2020 08:10
Var
x1,x2,x3,y1,y2,y3,r1,r1,r3: real;
begin
writeln ('введите координаты A');
readln (x1,y1);
writeln ('введите координаты B');
readln (x2,y2);
writeln ('введите координаты C');
readln (x3,y3);
r1:=sqrt(x1*x1+y1*y1);
r2:=sqrt(x2*x2+y2*y2);
r3:=sqrt(x3*x3+y3*y3);
if (r1<=r2) and (r1<=r3) writeln('точка А ближе');
if (r2<=r1) and (r2<=r3) writeln('точка B ближе');
if (r3<=r1) and (r3<=r2) writeln('точка C ближе');
readln;
end
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?