В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
68Diman
68Diman
06.01.2022 13:48 •  Информатика

1 вопрос Написать программу. Ввести c клавиатуры массив из 10 элементов, увеличить каждый элемент на 5 и вывести на экран.
2 вопрос
Написать программу. Ввести c клавиатуры массив из 10 элементов. Увеличить на 5 все элементы в первой половине
массива и увеличить в 5 раз все элементы во второй половине массива. Вывести на экран.
3 вопрос
Написать программу. Заполните массив A из 10 элементов пятерками.
ПАСКАЛЬ

Ответ:
danilgranin20
danilgranin20
21.12.2021 22:00

Program Exp_1;

Var

  a:array[1..5] of integer;

  i:integer;

Begin

    for i:=1 to 5 do

    Begin

     write('Vvedite ',i,'-yi element massiva ');

     Readln(a[i]);

    End;

Write('Ishodny massiv: ');

for i:=1 to 5 do

 write(a[i],' ');

writeln;

writeln('Poluchenny massiv: ');

for i:=1 to 5 do

 write(a[i]+5,' ');

 Readln;

End.

Program Exp_2;

Var

  a:array[1..10] of integer;

  i:integer;

Begin

    for i:=1 to 10 do

    Begin

     write('Vvedite ',i,'-yi element massiva ');

     Readln(a[i]);

    End;

Write('Ishodny massiv: ');

for i:=1 to 10 do

 write(a[i],' ');

writeln;

writeln('Poluchenny massiv: ');

for i:=1 to 5 do

 write(a[i]+5,' ');

for i:=6 to 10 do

 write(a[i]*5,' ');

 Readln;

End.

Program Exp_3;

Const

n=10;

Var

  a:array[1..n] of integer;

  i:integer;

Begin

    for i:=1 to n do

    begin

    a[i]:=5;

    write(a[i]:3);

    read;

    end;

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?