В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hplss
hplss
28.04.2021 17:04 •  Информатика

На вход программе подается список целых чисел. Используя любой алгоритм сортировки (пузырьком или камнем) найдите 3 наибольших элемента списка. Выведите эти элементы в любом порядке

Ответ:
ИльяК2806
ИльяК2806
21.12.2021 19:10

ответ:  список целых чисел - вводится через запятую

a = input()

s = []

snow = ''

while len(a) > 0:

   if a[0] != ',':

       if len(a) != 1:

           snow = snow + a[0]

           a = a[1:]

       else:

           snow = snow + a[0]

           s.append(int(snow))

           a = a[1:]

   else:

       s.append(int(snow))

       snow = ''

       a = a[1:]

s.sort()

s = list(reversed(s))

print(s[0], s[1], s[2])

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?