В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
glokol
glokol
03.10.2021 10:09 •  Информатика

, Нужно написать программу с рекурсивной функцией для умножения двух чисел А*В используя только операцию сложения.
С++

Ответ:
katarinemiels2
katarinemiels2
21.12.2021 15:40

#include <iostream>

double multiply(double num1, double num2) {

   if (num2 > 0) return num1 + multiply(num1, num2 - 1);

   else if (num2 < 0) return -num1 + multiply(num1, num2 + 1);

   return 0;

}

signed main() {

   

   //2.2 * 2

   std::cout << multiply(2.2, 2) << std::endl;

   //4 * 2

   std::cout << multiply(4, 2) << std::endl;

   //-8 * 2

   std::cout << multiply(-8, 2) << std::endl;

   //0*1

   std::cout << multiply(0, 1) << std::endl;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?