В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lynnikova05
lynnikova05
22.02.2022 21:16 •  Информатика

Написать программу в паскаль abc. теорема ферма утверждает, что не существует решения в целых числах уравнения x^n+y^n=z^n при n> 2. напишите программу, которая проверяла бы это утверждение при заданном n для всех x,y и z меньших 100.

Ответ:
MashaE631
MashaE631
25.06.2020 23:48
Если n небольшие, то можно написать так:
var
  x, y, z, n: integer;
  disproved: boolean;
begin
  write('Введите n: ');
  readln(n);
  disproved := false;
  for x := 1 to 100 do
    for y := 1 to 100 do
      for z := 1 to 100 do
        if power(x, n) + power(y, n) = power(z, n) then
        begin
          writeln('Ферма ошибся! ', x, ' ^ ', n, ' + ', y, ' ^ ', n, ' = ', z, ' ^ ', n);
          disproved := true;
        end;
  if not disproved then
    writeln('Теорема не опровергнута');
end.
При больших n уже придётся использовать длинную арифметику.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?