В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ExKise
ExKise
06.08.2020 22:44 •  Информатика

1) Напишите программу, которая находит
минимальный и максимальный из чётных элементов
массива. Гарантируется, что все элементы массива
находятся в диапазоне [-100;100] и среди них есть
хотя бы один чётный элемент.
2)Напишите программу, которая находит
минимальный и максимальный из элементов
массива, заканчивающихся на "5". Если в массиве
нет таких элементов, нужно вывести слово "нет".

Ответ:
timahipoDrakeylol
timahipoDrakeylol
06.02.2022 21:22

1)

a = [12,32,51,2,5,-10,-20,23,-23] # задаете любой массив

a.sort()

minim = 0

maxim = 0

for i in range(len(a)):

   if a[i] % 2 == 0:

       minim = a[i]

       break

a = list(reversed(a))

for i in range(len(a)):

   if a[i] % 2 == 0:

       maxim = a[i]

       break

print(minim)

print(maxim)

2)

a = [12,32,51,2,1,-10,-20,21,-23]

a.sort()

minim = 0

maxim = 0

for i in range(len(a)):

   if a[i] % 10 == 5:

       minim = a[i]

       break

a = list(reversed(a))

for i in range(len(a)):

   if a[i] % 10 == 5:

       maxim = a[i]

       break

if minim == 0 and maxim == 0:

   print('No')

else:

   print(minim)

   print(maxim)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?