Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
SofaI
05.05.2022 04:08 •
Информатика
Составить программу для нахождения корней квадратного уравнения ах2+вх+с
Ответ:
Yuki16
25.06.2020 21:11
Uses crt;
var
d, a, b, c, x1, x2: real;
begin
writeln('Введите a, b, c');
readln(a, b, c);
d := b * b - 4 * a * c;
if d > 0 then
begin
x1 := (-b + sqrt(d)) / (2 * a);
x2 := (-b - sqrt(d)) / (2 * a);
writeln('x1 = ', x1:2:2);
writeln('x2 = ', x2:2:2);
end
else if d = 0 then
begin
x1 := -b / (2 * a);
writeln('x = ', x1:2:2);
end
else
writeln('Нет действительных корней');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ksenia20012002
11.02.2022 15:34
Как дела ? что делаете ?кто играет (л) в кар паркинг ?...
lakomka2018
30.08.2022 06:34
Определите правильный порядок создания фигуры....
katyu1234
24.02.2021 18:25
1. Что такое текстовый редактор? А) Программа для работы с таблицами.В) Прикладная программа, которая позволяет создавать,редактировать и печатать текстовые документы.С)...
lizagileva2015
30.01.2022 16:10
Укажи количественный признак объкта книга...
daaaasha2018
30.01.2022 16:10
устройство вывода звуковой информации краткое описание...
Lulu8080
16.09.2022 13:02
У исполнителя Квадратор две команды, которым присвоены номера: 1. возведи в квадрат 2. прибавь b (b — неизвестное натуральное число) Первая из них возводит число на...
lnatahozqc8g
26.04.2023 22:47
Цитатный план по сказу медной горы хозяйка 30...
Чертенок22
26.04.2023 22:47
Люди хелп ми добычи делезной руды,известняка,каменного угля,нефти и гранита кратко....
Пони2000
12.05.2022 10:40
70 ! ! les pronoms -compléments d objet direct 1.indiquez-la nature des mots en caractère gras. exemple: je les vois.-» les - pronom personnel je vois les enfants....
Frog12321nik
12.05.2022 10:40
Пример трудно написать,вот это дробная часть: 3целых одна шестая + 5целых одна шестая разделить на 4целых две пятнадцатые умножить на три девяносто-вторых...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
d, a, b, c, x1, x2: real;
begin
writeln('Введите a, b, c');
readln(a, b, c);
d := b * b - 4 * a * c;
if d > 0 then
begin
x1 := (-b + sqrt(d)) / (2 * a);
x2 := (-b - sqrt(d)) / (2 * a);
writeln('x1 = ', x1:2:2);
writeln('x2 = ', x2:2:2);
end
else if d = 0 then
begin
x1 := -b / (2 * a);
writeln('x = ', x1:2:2);
end
else
writeln('Нет действительных корней');
end.