В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nikita1241
nikita1241
10.05.2021 08:22 •  Информатика

1. Заполните массив кубами случайных целых чисел в интервале (1,5). Перемножьте все элементы списка с четными индексами (то есть A[0], A[2], A[4], ...). Входные данные
Вводится список чисел. Все числа списка находятся на одной строке.
Выходные данные
Выведите ответ на задачу.

2. Заполните массив из 10 элементов. Выведите на экран произведение четных элементов.
Входные данные
Вводится список чисел. Все числа списка находятся на одной строке.
Выходные данные
Выведите ответ на задачу.

ответом на задачи является программа на языке python.

Ответ:
danilohca
danilohca
01.02.2022 07:51

Программа:

Python:

№1)

A = list(input().split())

pr = 1

for i in range(len(A)):

   if i % 2 == 0:

       pr *= int(A[i])

print(f'{A}\n{pr}')

№2)

from random import randint

arr = [randint(-10, 10) for i in range(10)]  # массив из 10 чисел от -10 до 10

pr = 1

for i in arr:

   if i % 2 == 0 and i != 0:  pr *= i

print(f'{arr}\n{pr}')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?