В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
7077788
7077788
28.03.2020 00:58 •  Информатика

1) На входе программы есть два целых числа, каждое в отдельной строке. На выход нужно подать сумму заданных чисел.
Входные данные
Два целых числа, записанных в столбик.
Выходные данные
Сумма заданных чисел.

Примеры
Ниже вы найдете примеры входных данных и ответов, которые должна вывести ваша программа.
12
9
ответ №1
21

2) Вам дано целое число n. Также есть три вида операций:
Уменьшить n на 1.
Увеличить n на 1.
Если n делится нацело на 3, разделите n на 3.
За какое минимальное количество сделок можно сделать число n равным 1?
Входные данные
Первая строка содержит одно целое число n (1≤n≤1018).
Выходные данные
Выведите одно число – минимальное количество операций, за которое можно сделать число n равным 1.
Примечание
В первом примере можно раз поделить на 3 и получим 1.
Во втором примере можно сначала дважды убавить n на 1, а затем разделить на 3.
Оценивание
Решения, работающие правильно для ограничений 1≤n≤105, будут набирать 40% .
Примеры
Ниже вы найдете примеры входных данных и ответов, которые должна вывести ваша программа.
Входные данные №1
3
ответ №1
1
Входные данные №2
5
ответ №2
3
Входные данные №5
70109
ответ №5
18

Ответ:
natalyakulesch
natalyakulesch
30.01.2022 22:17

1)

a = int(input('Введите первое число: '))

b = int(input('Введите второе число: '))

c = a + b

print(f'ответ: {c}')

2)

n = int(input('Целое число: '))

result = 0

if n >= 1:

  if n <= 1018:

     while n != 1:

        if (r := n % 3) == 0:

           n //= 3

        elif r == 1 or n == 2:

           n -= 1

        elif r == 2:

           n += 1

        result += 1

     print(f'Количество действий: {result}')

  else:

     print('Число больше 1018')

else:

  print('Число меньше 0 или равно 0')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?