В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Olegggg04
Olegggg04
05.12.2022 18:26 •  Информатика

C++ нужно написать программу которая бы из целого числа делала сумму чисел и произведение (в двух разных строчках)

Ответ:
209439an
209439an
04.12.2021 18:50

#include <iostream>

using namespace std;

int main(){

   string n;

   int sum;

   while (true){

       sum=0;

       cout<<"\nEnter integer : ";

       cin>>n;

       for (int i=0; i<n.size(); i++)

           sum+=n[i]-'0';

       cout<<"Sum of digits : "<<sum<<endl;

       system("pause");

   }

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?